Сетевое, серверное, телекоммуникационное и торговое оборудование, AutoID и видеонаблюдение, ИБП и АКБ

Настройка контроллера беспроводной сети Cisco AIR-CT2504

 

 

Введение

В данной статье рассмотрены основные аспекты внедрения беспроводной сети Cisco на основе контроллера WLC 2504. В статье представлены все этапы работы: от заказа контроллера до его инсталляции и поиска неисправностей. Статься начинается с общих технических характеристик контроллера, далее представлена информация для подготовки заказа и спецификации контроллера, далее идет описание первоначальной настройки контроллера, а затем подробно рассмотрен один сценарий настройки беспроводной сети.

1.    Характеристики контроллера 2504  AIR-CT2504

- Поддержка до 75 точек доступа и до 1000 клиентов

- Два порта с поддержкой PoE для прямого подключения точек доступа

- Пропускная способность до 1 Гбит/с

- Лицензии могут быть добавлены в процессе эксплуатации по мере роста числа точек доступа. При этом лицензии продаются пакетами по 1, 5 или 25 точек доступа.

- Поддержка стандартов Wi-Fi: IEEE 802.11a, 802.11b, 802.11g, 802.11d, WMM/802.11e, 802.11h, 802.11k, 802.11n, 802.11r, 802.11u, 802.11w, 802.11ac

- Поддержка шифрования: WEP и TKIP-MIC (с ключом длинной 40, 104 и 128 бит), AES, DES, 3DES, SSL, TLS, DTLS

- Поддержка CleanAir

- Поддержка Unified Communication

- Поддержка IP телефонов

- Поддержка технологии Cisco VideoStream

- Возможность монтажа в стойку

2.   Заказ и комплектность поставки.

Ниже приведен пример заказа WLC 2504 c лицензией на 5 точек доступа

Номер п.п.

Наименование (партийний номер)

Описание

Кол-во

Цена в GPL, $ 

1.0

AIR-CT2504-5-K9

2504 Wireless Controller with 5 AP Licenses

1

1 295,00 

1.1

AIR-CT2504-K9

2504 Wireless Controller with 0 AP Licenses

1

0,00 

1.2

AIR-CT2504-SW-7.6

2504 Wireless Controller SW Rel. 7.6

1

0,00 

1.3

CAB-AC2E

AC Power cord Europe

1

0,00 

1.4

AIR-CT2504-RMNT

2504 Wireless Controller Rack Mount Bracket

1

95,00 

1.5

AIR-CT2504-CCBL

2504 Wireless Controller Console Cable

1

0,00 

1.6

LIC-CT2504-5

5 AP License for 2504 WLAN Controller

1

0,00 

1.7

LIC-CT2504-BASE

Base Software License

1

0,00 

1.8

PS-SWITCH-AC-2P

2 Prong C7/C8 On-Off AC Power Supply Switch

1

0,00 

1.9

LIC-CT25-DTLS-K9

2504 Wireless Controller DTLS License

1

0,00 

 

1.1   AIR-CT2504-K9 – сам контроллер

air-ct2504-5-k9

1.2   AIR-CT2504-SW-7.6 – программное обеспечение, если не удается заказать контроллер с последней версией ПО, рекомендуется обновить до версии 7.6: AIR-CT2500-K9-7-6-110-0.aes. С версией до 7.5 могут наблюдаться проблемы связанные с выводом точек доступа на максимальную мощность.

1.3   CAB-AC2E – кабель питания

cab-ac2e

1.4   AIR-CT2504-RMNT
– крепление для серверной стойки. Могут быть заказаны как в составе заказа контроллера, так и отдельно. Стоят отдельных денег. Если отдельно, то парт номер будет со знаком «=» на конце: AIR-CT2504-RMNT=

air-ct2504-rmnt

1.5   AIR-CT2504-CCBL – консольный кабель

air-ct2504-ccbl

 

1.6   LIC-CT2504-5 – лицензия на 5 точек доступа, будет уже в составе контроллера, отдельной установки не требуется. Для увеличения количества точек доступа, поддерживаемых контороллером, необходимо заказывать L-LIC-CT2504-UPG, в которую могут быть включены лицензии на 1 точку доступа (L-LIC-CT2504-1A), на 5 точек - L-LIC-CT2504-5A, и на 25 точек доступа - L-LIC-CT2504-25A.

1.7   LIC-CT2504-BASE – лицензия на ПО, в составе контроллера, отдельной установки не требуется.

1.8   PS-SWITCH-AC-2P – блок питания с кнопкой включения

ps-switch-ac-2p

1.9   LIC-CT25-DTLS-K9 – Лицензия шифрования данных, активирует возможность шифрования пользовательского трафика

 

Беспроводные точки доступа, поддерживаемые WLC 2504:

Lightweight APs: 1040, 1130, 1140, 1240, 1250, 1260, 1600, 2600, 2700, 3500e, 3500i, 3500p, 3600e, 3600i, 3600p, 3702e, 3702i, 3702p, 600 OEAP, 700, 700W, AP801, AP802

Outdoor Mesh APs: 1522, 1524PS, 1524SB, 1532E, 1532I, 1552E, 1552H, 1552I, 1552C, 1552EU, 1552CU,  1552S

 

3.    Первоначальная настройка контроллера WLC 2504 

Подключившись консольным кабелем к контроллеру, выполняем первоначальную настройку.

Иногда бывает, что зависает подсистема Auto-install. Контроллер будет “пинговаться”, но будет казаться, что система зависла. При этом если подключиться той же самой консолью к любому другому устройству Cisco, можно будет убедиться, что консольный кабель исправен. Решение такое: отключить flow control в настройках гипер-терминала. Дополнительно, клиент SecureCRT может вызывать подобный эффект.

И так, подключились консолью, видим следующее приглашение.

 

Would you like to terminate autoinstall? [yes]:

 

Функция autoinstall предусматривает автоматическую настройку контроллера с заранее заготовленного конфигурационного файла. Для этого необходимо иметь DHCP сервер, TFTP сервер с конфигурационным файлом. При включении контроллер получает IP адрес с опцией адреса TFTP сервера, на котором хранится конфигурационный файл. Контроллер скачивает этот файл и применяет его в настройки. Чтобы завершить попытки контроллера получить IP адрес и выполнить автоматическую настройку, соглашаемся с предложением, выбирая “yes” (достаточно просто нажать на Enter) и приступаем к ручной первичной настройке.

 

AUTO-INSTALL: process terminated -- no configuration loaded

 

Задаем логин и пароль администратора. На данном этапе настройки к паролю предъявляются довольно-таки серьезные требования: верхний и нижний регистры плюс цифры и длинна не меньше 8 символов. Для того чтобы создать более простой пароль, можно будет потом в меню изменить политики безопасности, создать нового пользователя с более простым паролем.

 

Enter Administrative User Name: cisco

Enter Administrative Password (3 to 24 characters): ***********

Re-enter Administrative Password                 : ***********

 

Если нет необходимости, отключаем Link Aggregation

 

Enable Link Aggregation (LAG) [yes][NO]:

 

Задаем IP адрес, маску и шлюз по умолчанию для интерфейса управления точками доступа. Именно в этой подсети точки доступа будут обмениваться сообщениями с контроллером, по этому адресу будет доступно управление контроллером в режиме GUI и CLI

 

Management Interface IP Address: 10.1.10.253

Management Interface Netmask: 255.255.255.0

Management Interface Default Router: 0

 

Выбираем номер VLANа и тип порта для интерфейса управления. В данном примере говорится что адрес управления будет в 10 vlan-е.

Management Interface VLAN Identifier (0 = untagged): 10

 

Выбираем физический интерфейс для адреса управления

Management Interface Port Num [1 to 4]: 1

 

Вводим адрес DHCP сервера, который будет раздавать адрес точкам доступа.

Management Interface DHCP Server IP Address: 10.1.10.254

 

Зачастую не требуется, но поле пустым оставить нельзя, поэтому можно ввести следующий адрес

Virtual Gateway IP Address: 1.1.1.1

 

Зачастую не требуется, но поле пустым оставить нельзя, поэтому можно ввести следующий адрес

Multicast IP Address: 236.1.1.1

 

Следующие настройки на данном этапе не сильно важны, можно выбрать любые или настроить их позже.

 

Mobility/RF Group Name: Laboratory

Network Name (SSID): temp

Configure DHCP Bridging Mode [yes][NO]:

Allow Static IP Addresses [YES][no]:

Configure a RADIUS Server now? [YES][no]: no

Warning! The default WLAN security policy requires a RADIUS server.

Please see documentation for more details.

 

Очень важно правильно выбрать регион. Если точки доступа для России, а выбрать регион другую страну, с другим радио частотным регламентом, то точки доступа не зарегистрируются на контроллере. В логах будет сообщение о несоответствии региона.

Enter Country Code list (enter 'help' for a list of countries) [US]: RU

 

Остальные настройки можно пока оставить такими: включить радио сеть, включить автоматическую настройку мощности передатчика и канала, а настройки времени и синхронизацию времени по NTP отложить на потом.

Enable 802.11b Network [YES][no]:

Enable 802.11a Network [YES][no]:

Enable 802.11g Network [YES][no]:

Enable Auto-RF [YES][no]:

 

Configure a NTP server now? [YES][no]: no

Configure the system time now? [YES][no]: no

Warning! No AP will come up unless the time is set.

Please see documentation for more details.

 

Сохраняем настройки, после чего контроллер перезагрузится и будет уже доступен по адресу 10.1.10.253

Configuration correct? If yes, system will save it and reset. [yes][NO]: yes

 

Теперь требуется настройка коммутатора, через который подключены контроллер и компьютер администратора. Схема подключения выглядит следующим образом.

Схема подключения контроллера

На коммутаторе настраиваем порты следующим образом:

vlan 10

name Management_ AP

interface GigabitEthernet0/1

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 10

switchport mode trunk

interface GigabitEthernet0/2

switchport

switchport mode access

switchport access vlan 10

End

 

Первоначальная настройка готова, заходим через WEB браузер по адресу https://10.1.10.253 и можно приступать к полной настройке контроллера.

4.    Типичный сценарий настройки контроллера

Рассмотрим следующую схему подключения.

Схема подключения

Задача создать две беспроводные сети Guest и Corporate. Права и доступ к корпоративным ресурсам и сети Интернет настраиваются на существующей сети передачи данных. Беспроводная сеть – это только новые VLAN-ы в существующей сети.

 

Начнем с настройки коммутатора (ядра сети), для нашего случая настройка будет выглядеть так:

vlan 10

name Management_ AP

vlan 20

name Corporate

vlan 30

name Guest

!

interface GigabitEthernet0/1

 description WLC

 switchport trunk encapsulation dot1q

 switchport trunk allowed vlan 10,20,30

 switchport mode trunk

!

interface range GigabitEthernet 0/2-4

 switchport access vlan 10

 switchport mode access

!

interface vlan 10

description Management_ AP

ip address 10.1.10.254 255.255.255.0

interface vlan 20

description Corporate

ip address 10.1.20. 254 255.255.255.0

interface vlan 30

description Guest

ip address 10.1.30. 254 255.255.255.0

 

 

 

ip dhcp excluded-address 10.1.10.200

ip dhcp excluded-address 10.1.10.253

ip dhcp excluded-address 10.1.10.254

ip dhcp excluded-address 10.1.20.254

ip dhcp excluded-address 10.1.30.254

!

ip dhcp pool Management_ AP

 network 10.1.10.0 255.255.255.0

 default-router 10.1.10.254

!

ip dhcp pool Corporate

 network 10.1.20.0 255.255.255.0

 default-router 10.1.20.254

!

ip dhcp pool Guest

 network 10.1.30.0 255.255.255.0

 default-router 10.1.30.254

 

Подключаемся браузером по адресу https://10.1.10.253. Настройка WLC будет выглядеть следующим образом.

  1. Начальная страница выглядит так. Здесь следует обратить внимание на версию программного обеспечения, при необходимости, обновить до последней версии. Далее, обратить внимание на количество лицензий для точек доступа. В данном примере ПО версии 7.6.110.0 и лицензия на 5 точек доступа.

Начальная страница

2.  На вкладке CONTROLLER, меню GENERAL, в поле NAME меняем имя WLC на нужное. Это имя будет видно в CDP.

Изменяем имя

3.  На вкладке CONTROLLER, меню INTERFACES добавляем новые интерфейсы, привязывая их к порту PORT1

Меню интерфейса

4.  Добавляем интерфейс Corporate, привязывая его к порту PORT1

Привязка к порту

5.  Аналогичным образом добавляем интерфейс Guest

Добавляем интерфейс  

6.  На вкладке WLANs, меню WLANs, подменю WLANs удаляем временную SSID с именем temp и создаем новые, нажав на кнопку GO

Удаление временного параметра

7.  Указать название профиля и имя SSID (имя, как будет называться сеть в радио эфире)

Имя

8.  Поставить галочку Status – Enabled, для того чтобы разрешить работу этой сети. Выбрать нужный интерфейс привязки его к SSID.

status_enabled

9.  Настроить параметры шифрования и установить пароль, если используется аутентификация по PSK

Параметры шифрования

10.  Аналогичные процедуры для сети Guest, настройка общих параметров и безопасности

Для сети

nastrojka_obwih_parametrov

11.  Итого, имеем две сети

Две сети

12.  Далее, на вкладке WIRELESS, меню 802.11a/n/ac и 802.11 b/g/n, подменю CleanAir, активируем CleanAir (по умолчанию функции выключена)

Активация

13.  На вкладке WIRELESS, меню 802.11a/n/ac и 802.11 b/g/n, подменю RRM (Radio Resourse Management), TPC (Tx Power Control) выбираем режим покрытия (оптимизация по покрытию, когда точки достаточно далеко друг от друга и плотность клиентов не велика, или оптимизация по интерференции, когда плотность клиентов большая и точки близко друг к другу), выбираем режим управления мощностью: автоматический или ручной. В обоих режимах можно задать минимальную мощность передатчика в поле “Minimum Power Level Assignment”.

Таблица соответствия мощности в dBm и mW.

dBm

mW

0

1

9

8

10

10

12

16

15

32

14

25

16

40

18

63

19

79

20

100

Для большинства случаев, наиболее оптимальный диапазон мощности – от 10mW до 63 mW. Соответственно, разумно установить минимальный порог мощности на 10 dBm, а режим управления мощности на Auto. Для сети 802.11b/g/n проделать аналогичное.

Режим управления мощности

14.  Для удобства управления, можно разрешить администрирование WLC через Wi-Fi. Для этого в меню MANAGEMENT, подменю «Mgmt Via Wireless» установить галочку Enable

mgmt_via_wireless

15.  Для того чтобы работал роуминг между базовыми станциями, необходимо создать группу и добавить туда все точки доступа. Для этого зайти в раздел WLANs, меню Advances, подменю AP Group, создать новую группу (или редактировать группу default-group)

ap_group

ap_group

16.  Далее, сопоставить все интерфейсы с SSID

Сопоставление интерфейсов

Сопоставление интерфейсов

17.  И наконец, на вкладке Aps, добавить все точки доступа с правого столбца в левый. Все точки доступа перезагрузятся. Роуминг будет работать.

Добавление точек доступа

На этом основная настройка контроллера закончена.

После всех настроек рекомендуется проверить реальную мощность точек доступа. Для этого зайти на контроллер по SSH и посмотреть вывод команды “show advanced 802.11b txpower”

(Cisco Controller) >show advanced 802.11b txpower

Min Transmit Power............................. 10 dBm

Max Transmit Power............................. 30 dBm

AP Name                          Channel    TxPower       Allowed Power Levels

-------------------------------- ---------- ------------- ------------------------

AP1                             *11        *3/5 (12 dBm) [18/15/12/9/6/6/6/6]

AP2                             *6         *3/5 (12 dBm) [18/15/12/9/6/6/6/6]

AP3                             *11        *3/5 (12 dBm) [18/15/12/9/6/6/6/6]

AP4                             *1         *3/5 (12 dBm) [18/15/12/9/6/6/6/6]

Точка доступа может менять значение мощности с шагом в 3 дБ. Это значит, что каждый новый шаг в два раза по мощности отличается от предыдущего. В данном примере, точка доступа 2602 имеет максимальную мощность 18dBm (63mW). В соответствии с настройками, она может уменьшать мощность до 12 dBm (16mW) включительно. Нижнюю границу мощности устанавливали на 10 dBm, а шаг изменения мощности равен 3 dBm.

Уровень мощности равный 1 соответствует максимальной мощности, то есть 18dBm. Уровень мощности 2 соответствует в два раза меньшей мощности, 15 dBm и так далее.

В WEB интерфейсе это можно посмотреть в разделе WIRELESS, меню Access points, подменю Radios и далее 802.11a/n/ac и 802.11b/g/n соответственно:

Radios

На этом основная настройка завершена.